[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Edlug Archive Mar 2007 ]

Re: [edlug] Apache2 woes




Oops! I sent this to William and not the list. Sorry William!


r.

On 5 Mar 2007, at 10:03, William Anderson wrote:

I've looked through my httpd.conf and it all _looks_ fine.

Any ideas?

try running apache2ctl configtest to see where there are any errors in
your apache configs which might prevent httpd from being spun up.

If I comment out the following in httpd.conf it starts fine:


<VirtualHost *>
        ServerAdmin admin@xxx.xxx.xxx
        ServerName www.interfunt.com
        ServerAlias interfunt.com
        DocumentRoot /var/www/interfunt.com/htdocs/

        <Directory />
        Options +Includes
        </Directory>

        ErrorLog /var/www/interfunt.com/logs/error.log
        CustomLog /var/www/interfunt.com/logs/access.log combined
</VirtualHost>

This all looks fine to me. Or have I missed something?

Furthermore I've now narrowed it down to:


<VirtualHost *>
        ServerAdmin admin@xxx.xxx.xxx
        ServerName www.interfunt.com
#       ServerAlias interfunt.com
        DocumentRoot /var/www/interfunt.com/htdocs/

        <Directory />
        Options +Includes
        </Directory>
#
#       ErrorLog /var/www/interfunt.com/logs/error.log
#       CustomLog /var/www/interfunt.com/log/access.log combined
</VirtualHost>

I can't muck about with it any more tonight as some sites need to be running.

r.

-
----------------------------------------------------------------------
You can find the EdLUG mailing list FAQ list at:
http://www.edlug.org.uk/list_faq.html



This archive is kept by wibble+RM@xxx.xxx.xxx
Morpheux
HomePage